Elevated latencies and delays

Incident Report for LaunchDarkly Federal

Resolved

The issue with elevated latencies and delays has been resolved. Impacted services have returned to normal operation.
Posted Oct 21, 2025 - 02:53 PDT

Monitoring

Systems have recovered to healthy levels and we're continuing to monitor the system's metrics.
Posted Oct 20, 2025 - 08:08 PDT

Update

We are still experiencing delays in flag updates and event ingestion pipeline, affecting experimentation, data export, flag status metrics and others.
Posted Oct 20, 2025 - 06:07 PDT

Update

We are still experiencing delays in flag updates and event ingestion pipeline, affecting experimentation, data export, flag status metrics and others.
Posted Oct 20, 2025 - 04:56 PDT

Update

We are seeing initial recovery for the following services

- Flag updates

We are monitoring for the recovery of the rest of the services.
Posted Oct 20, 2025 - 03:16 PDT

Update

We are continuing to work on the issue. Additionally impacted services

- Delayed flag updates to SDKs
- Dropped SDK events impacting Experimentation, Data Export
Posted Oct 20, 2025 - 01:54 PDT

Identified

We have identified issue with elevated error rates and event pipelines. Currently impacted services are

- Guarded rollouts
- Scheduled flag changes
- Experimentation
- Data export
- Flag usage metrics
- Emails and notifications
- Integrations web hooks
Posted Oct 20, 2025 - 01:05 PDT
This incident affected: Automations (non-core functionality) (Emails and notifications, Integrations and webhooks), Experimentation (core functionality) (Experiment results processing), and Feature management (non-core functionality) (Context processing, Data Export, Flag usage metrics).